-->

Could not update the metadata that indicates database is enabled for Change Data Capture. The failure occurred when executing the command SetCDCTracked(Value = 1)

Post a Comment

I got this  error message when I was trying to enable CDC on a SQL Server  database for

“

Msg 22830, Level 16, State 1, Procedure sp_cdc_enable_db_internal, Line 193
Could not update the metadata that indicates database XXXXX is enabled for Change Data Capture.
The failure occurred when executing the command 'SetCDCTracked(Value = 1)'. The error returned was 15404:
'Could not obtain information about Windows NT group/user 'XXXX\xxxxxxx', error code 0x5.'.
Use the action and error to determine the cause of the failure and resubmit the request.

“

 

The fix for this is to change the database owner to "sa" by executing the below script.

USE <Database>

GO

EXEC sp_changedbowner 'sa'

Read the below KB article for more details.

http://support.microsoft.com/kb/913423

Related Posts

There is no other posts in this category.

Post a Comment

Subscribe Our Newsletter